Фирма решила открыть на основе технологии производства чешского стекла

Фирма решила открыть на основе технологии производства чешского стекла, фарфора и хрусталя линию по изготовлению ваз и графинов и их декорированию. Затраты сырья на производство этой продукции представлены в таблице:

Сырье Расход сырья на производство, г
Поставки сырья в неделю, кг.

ваза графин
Кобальт 20 18 30
Золото 13 10 12
Оптовая цена,
руб./шт. 700 560

Определите оптимальный объем выпуска продукции, обеспечивающий максимальный доход от продаж, если спрос на вазы не превышает 200 шт. в неделю.

Решение:
Построение математической модели
Рассчитаем целевую функцию — прибыль предприятия от изготовления изделий.
Обозначим x- число выпускаемых ваз;
y — число выпускаемых графинов.
Тогда доход в неделю составит составит:
z=700x+560y
Значения x нельзя выбирать произвольно. Рассмотрим ограничения, накладываемые на эти переменные. Таких ограничений четыре.
а) По физическому смыслу переменных. Количество выпускаемых изделий не может быть отрицательным, т.е.
x >= 0,
y >= 0.
б)По ограничению ресурса кобальт:
20x+18y<=30000
в)По ограничению ресурса золото:
13x+10y<=12000
г)По максимальному спросу на вазы, в неделю:
x<=200
Таким образом получим математическую модель задачи
z=700x+560y max
20x+18y≤3000013x+10y≤12000
при x, y >=0

Разработка начального плана выпуска продукции в ЭТ
В ячейках А1:D6 ЭТ разместим исходные данные о переменных x и y .
В ячейках Е3:F4 поместим данные о коэффициентах левой части системы неравенств.
В строках 6-7 введем информацию о целевой функции:
а)в ячейках В7 и С7 разместим коэффициенты перед переменными в целевой функции Z;
б)в ячейку D7 введем формулу для вычисления значения целевой функции.
Можно ввести формулу =В4*В8+С4*С8, а можно воспользоваться функцией =СУММПРОИЗВ(В4:С4;В8:С8).
В строках 9-13 разместим данные для проверки выполнения системы ограничений:
а)в ячейку А11 введем формулу для вычисления левой части первого неравенства из системы.
=СУММПРОЮВ(В4:С4;Е3^3).
В ячейке A13 формула =СУММПРОИЗВ(В$4:С$4;Е5^5)
В ячейки F11:F13 введем правые части неравенств системы.
1295404652010

Запускаем режим «Поиск решения». Для этого выполним команды Сервис — Поиск решения. Появится окно Поиск решения
В поле Установить целевую ячейку ввести D7
Выбрать режим поиска
Равной Максимальному значению
В поле Изменяя ячейки (Параметры функции) ввести В4:С4.
Чтобы ввести ограничения, щелкнуть по кнопке Добавить. Появится окно Изменение ограничения (Ограничения значений параметров).
Ввести ограничения:
В4:С4 > 0
А10:А11 < F10:F11.
1200156642735В4:С4 = целое (установить флажок Только положительные значения кнопка Параметры)

После каждого ограничения щелкнуть по кнопке Добавить (Ок), после последнего Ок.
Щелкнуть по кнопке Выполнить (Решить). В результате получим оптимальный план выпуска продукции
2438401251585

Для получения сплавов А и В используются четыре металла I, II. III и
IV.Требования к содержанию этих металлов в сплавах приведены в табл. 7.
Таблица 7
Сплав Требования к содержанию
металла Сплав Требования к
содержанию металла
А

Не более 70% металла I B

От 30% до 60% металла II

Не более 50% металла II
Не менее 50% металла III

Не более 60% металла IY

Характеристики и запасы руд, из которых получают металлы I, II. III и IY, указаны в табл. 8.
Таблица 8
Руда Максимальный запас, тонны Состав, % Цена, доллары за тонну

I II III IV Другие компоненты
1 2500 30 20 20 20 10 55
2 4000 35 25 10 20 10 70
3 3000 20 25 40 5 10 70

Цена одной тонны сплава А равна $450, а одной тонны сплава В – $550.
Необходимо максимизировать прибыль от продажи сплавов А и В.
Решение:
Построение математической модели
Определение целевой функции
Обозначим количество металлов I, II, III, IV, использованных для получения сплава А, переменными Х1А, Х2А, Х3А, Х4А. Количество металлов I, II, III, IV, использованных для получения сплава В, обозначим переменными Х1В, Х2В, Х3В, Х4В.
Для обозначения количества используемой руды введем переменные Y1, Y2, Y3.
Объем производимого сплава А (в тоннах) равен
Х1А +Х2А+Х3А+Х4А.
Аналогично объем сплава В равен
Х1В +Х2В +Х3В+Х4В.
Прибыль от продажи сплава А составит
Z1 = 450*(Х1А +Х2А+Х3А+Х4А),(1)
а прибыль от продажи сплава В равна
Z2 = 550*(Х1В +Х2В +Х3В+Х4В). (2)
Стоимость руд, использованных при литье металлов, равна
Z3 = 55Y1 + 70Y2 + 70Y3.(3)
Тогда целевую функцию – прибыль предприятия – можно записать в виде разности между прибылью от продажи сплавов и затратами на руды
Z =Z1 +Z2 -Z3. (4)
Или, подставляя выражения (1), (2) и (3) получим
Z = 450 (Х1А +Х2А +Х3А +Х4А)+550 (Х1В + Х2В + Х3В + Х4В) -55 Y1-70 Y2 – 70 Y3. (5)
1.2. Определение ограничений на переменные
Можно выделить четыре вида ограничений:
а) По физическому смыслу переменных – объемы используемых металлов и руд не могут быть отрицательными, следовательно
XiA≥0, XiB≥0, Yi≥0, i=1,2,3,4i=1,2,3,4i=1,2,3 (6)
б) Ограничения на состав сплавов. Согласно табл.7, получаем
(7)
в) Ограничения на состав металлов согласно табл. 8:
(8)
г) ограничения по запасам руды:
Y1≤2500Y2≤4000Y4≤3000 (9)
Итак, для решения задачи нужно найти такие значения расходуемых объемов металлов Х1А,Х2А,Х3А,Х4А,Х1В,Х2В,Х3В,Х4В и рудY1, Y2,Y3, которые обеспечат максимальное значение целевой функции (5) при выполнении ограничений (6) – (9).
2. Построение начального плана решения
1. Отведем под переменные Х1А,Х2А,Х3А,Х4Адиапазон ячеек В4:В7 электронной таблицы (в табл. 9 ЭТ приведена в режиме показа вычислений, в табл. 10 – в режиме показа формулExcel).
Таблица 9

A B C D E F G H I J K
1 Оптимальный состав сплава
2
Сплав
3 Металл А В Руда Состав металлов
4 1 0 0 Номер Затраты Запас Цена I II III IY
5 2 0 0 1 0 2500 55 0.30 0.20 0.20 0.20
6 3 0 0 2 0 4000 70 0.35 0.25 0.10 0.20
7 4 0 0 3 0 3000 70 0.20 0.25 0.40 0.05
8 Ограничения
9 Левая часть Правая часть
10 0 0
11 0 0
12 0 0
13 0 0
14 0 0
15 0 0
16 0 0
17 0 0
18 0 0
19 0 0
20 Целевая функция
21 0
2. Для хранения переменных Х1В,Х2В,Х3В,Х4Вотведем диапазон ячеекС4:С7электронной таблицы.
3. В ячейках Е5:Е7разместим значения переменныхY1, Y2,Y3. Для всех переменных начальные значения полагаем равными нулю.
4. В диапазоне ячеек F5:F7вводим значения имеющихся запасов руды из второго столбца табл. 48.
5. В диапазон ячеек G5:G7вводим цены за одну тонну руды из последнего столбца табл. 48.
6. В диапазон ячеек Н5:К7помещаем характеристики состава руд из столбцов 3 – 6 табл. 49.
7. В ячейки диапазона А10:А15вводим левые части ограничений (22).
8. В ячейки диапазона Е10:Е15вводим правые части ограничений (22).
9. В ячейки диапазона А16:А19вводим левые части ограничений (23).
10. В ячейки диапазона Е16:Е19вводим правые части ограничений (23).
11. В ячейке А21размещаем целевую функцию (20).
3. Оптимизация плана решения
Вызываем режим Поиск решения(Сервис–Поиск решения).
Заполняем окно Поиск решения.
Командой Выполнитьзапускаем режимПоиск решения.
Результат его работы представлен в табл. 53.
Таблица 51
  A B C D E F G H I J K
1 Оптимальный состав сплава
2   Сплав
3 Металл А В Руда Состав металлов
4 1 0 0 Номер Затраты Запас Цена I II III IY
5 2 0 0 1 0 2500 55 0.3 0.2 0.2 0.2
6 3 0 0 2 0 4000 70 0.35 0.25 0.1 0.2
7 4 0 0 3 0 3000 70 0.2 0.25 0.4 0.05
8 Ограничения
9 Левая часть Правая часть
10 =В4
=0.7*СУММ(B4:B7)
11 =В5 =0.5*СУММ(B4:B7)
12 =С5 =0.6*СУММ(C4:C7)
13 =С5 =0.3*СУММ(C4:C7)
14 =С6
=0.5*СУММ(C4:C7)
15 =С7
=0.6*СУММ(C4:C7)
16 =СУММ(B4:C4)
=СУММПРОИЗВ(E5:E7;H5:H7)
17 =СУММ(B5:C5)
=СУММПРОИЗВ(E5:E7;I5:I7)
18 =СУММ(B6:C6)
=СУММПРОИЗВ(E5:E7;J5:J7)
19 =СУММ(B7:C7)
=СУММПРОИЗВ(E5:E7;K5:K7)
20 Целевая функция
21 =450*СУММ(B4:B7)+550*СУММ(C4:C7)-
СУММПРОИЗВ(E5:E7;G5:G7)

Excel Microsoft Office
Таблица 53

A B C D E F G H I J K
1 Оптимальный состав сплава
2
Сплав
3 Металл А В Руда Состав металлов
4 1 2750 0 Номер Затраты Запас Цена I II III IY
5 2 150 2100 1 2500 1000 30 0,2 0,1 0,3 0,3
6 3 0 2100 2 4000 2000 40 0,1 0,2 0,3 0,3
7 4 1450 0 3 3000 3000 50 0,05 0,1 0,7 0,2
8 Ограничения
9 Левая часть Правая часть
10 2750 3045
11 150 2175
12 2100 2520
13 2100 1260
14 2100 2100
15 0 2520
16 2750 2750
17 2250 2250
18 2100 2100
19 1450 1450
20 Целевая функция
21 3640000

Вариант 39
Разработать информационно-логическую модель предметной области «Банк» с атрибутами
Отдел Стаж работы в банке
Секция Оклад
Фамилия, имя сотрудника Персональная надбавка
Образование Льготы
Учебное заведение Налог
Специальность Зарплата
Должность С каким предприятием работает
Общий стаж Номер счета предприятия
Создать логическую структуру этой базы данных для СУБД Access. Заполнить таблицы базы данных записями.
Создать отчёт с параметрами Отдел, Фамилия, имя сотрудника, Зарплата.
Создать запрос о сотрудниках, работающих с конкретным предприятием.

Решение:
Создадим следующие таблицы:
Отделы

Сотрудники

Зарплата

Клиенты

Обозначим связи между таблицами

Создадим отчет с параметрами: Отдел, Фамилия, Имя сотрудника, Зарплата

Создадим запрос о сотрудниках, работающих с конкретным предприятием

Запрос будет выглядеть следующим образом:

Вводим наименование интересующего предприятия, например ОАО «Стройка» и получаем результат:

Рейтинг
( 1 оценка, среднее 5 из 5 )
Понравилась статья? Поделиться с друзьями:
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!:

семнадцать + три =

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.

Adblock detector